The element that contains the rebar.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetHostId(
Document doc,
ElementId hostId
)
Public Sub SetHostId (
doc As Document,
hostId As ElementId
)
public:
void SetHostId(
Document^ doc,
ElementId^ hostId
)
member SetHostId :
doc : Document *
hostId : ElementId -> unit
Parameters
- doc Document
-
The document containing both this element and the host element.
- hostId ElementId
-
The element that the rebar object belongs to, such as a structural
wall, floor, foundation, beam, brace or column. The rebar does not need
to be strictly inside the host, but it must be assigned to one host
element.
Exceptions
See Also