RebarGetLapLength Method

Gets the lap length that is used for the specified end - 0 for start, 1 for end.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public double GetLapLength(
	int barEnd
)

Parameters

barEnd  Int32
The end where the splice is - 0 for start, 1 for end.

Return Value

Double
Returns the lap length that is used for the specified end - 0 for start, 1 for end.
Exceptions
ExceptionCondition
ArgumentException There is no splice at the specified end.
ArgumentOutOfRangeException barEnd must be 0 or 1.
See Also