RebarCanBeMatchedWithMultipleShapes Method |
Checks if this Rebar can be matched with multiple Rebar Shapes.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool CanBeMatchedWithMultipleShapes()
Public Function CanBeMatchedWithMultipleShapes As Boolean
public:
bool CanBeMatchedWithMultipleShapes()
member CanBeMatchedWithMultipleShapes : unit -> bool
Return Value
Boolean
Returns true if this Rebar can be matched with multiple Rebar Shapes, false otherwise.
Remarks A Free Form Rebar that has Workshop Instructions set to Bent is considered that can be matched with multiple shapes.
A Free Form Rebar that has Workshop Instructions set to Straight or a Shape Driven Rebar is considered that can be matched with only one shape.
See Also