DirectShapeType Class

The type element associated with a DirectShape element. This element includes data reused by DirectShape elements of the same type.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBDirectShapeType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DirectShapeType : ElementType

The DirectShapeType type exposes the following members.

Properties
 NameDescription
Public propertyUserAssignability An option controlling the ability of DirectShapes to assign this DirectShapeType as its type.
Top
Methods
 NameDescription
Public methodAddExternallyTaggedGeometry Adds the externally tagged geometry object to the DirectShapeType.
Public methodAddReferenceCurve(Curve) Adds a reference curve to the DirectShapeType.
Public methodAddReferenceCurve(Curve, DirectShapeReferenceOptions) Adds a reference curve to the DirectShapeType.
Public methodAddReferencePlane(Plane) Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public methodAddReferencePlane(Plane, BoundingBoxUV) Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public methodAddReferencePlane(Plane, DirectShapeReferenceOptions) Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public methodAddReferencePlane(Plane, BoundingBoxUV, DirectShapeReferenceOptions) Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Public methodAddReferencePoint(XYZ) Adds a reference point to the DirectShapeType.
Public methodAddReferencePoint(XYZ, DirectShapeReferenceOptions) Adds a reference point to the DirectShapeType.
Public methodAppendShape(IListGeometryObject) Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Public methodAppendShape(ShapeBuilder) Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType. The data stored in the supplied ShapeBuilder object will be cleared.
Public methodAppendShape(IListGeometryObject, DirectShapeTargetViewType) Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType. Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Public methodAreOptionsValid Validates that the given DirectShapeTypeOptions are allowed for this particular DirectShapeType.
Public methodAreValidDirectShapeReferenceOptions Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object. If the options specify an ExternalGeometryId, it must not correspond to any existing reference object belonging to the DirectShapeType.
Public methodCanChangeFamilyName Checks whether the DirectShapeType supports a custom family name.
Public methodCanCreateParts Indicates if it is possible to create parts from this DirectShapeType element.
Public methodStatic memberCreate(Document, String, ElementId) Creates a DirectShapeType element.
Public methodStatic memberCreate(Document, String, ElementId, DirectShapeTypeOptions) Creates a DirectShapeType element.
Public methodGetExternallyTaggedGeometry Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Public methodGetExternallyTaggedReference Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Public methodGetOptions Gets a copy of the current options for this DirectShapeType.
Public methodHasExternalGeometry Checks whether the externally tagged geometry is already present in this DirectShapeType.
Public methodHasExternallyTaggedReference Checks if the externally tagged reference is already present in this DirectShapeType.
Public methodStatic memberIsValidReferenceCurve Validates that the input curve is suitable for creating a direct shape type reference curve. Bounded and unbounded lines are accepted. Other bounded and unbounded curve types with natural bounds are accepted if they are not closed. Unbounded periodic curves are not allowed.
Public methodStatic memberIsValidReferencePlaneBoundingBoxUV Validates that the input BoundingBoxUV is suitable for bounding a reference plane surface. The input BoundingBoxUV must be set and not degenerate.
Public methodIsValidShape(ExternallyTaggedGeometryObject) Validates shape to be stored in a DirectShapeType.
Public methodIsValidShape(IListGeometryObject) Validates shape to be stored in a DirectShapeType.
Public methodIsValidShape(IListGeometryObject, DirectShapeTargetViewType) Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Public methodIsValidUsage Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Public methodRemoveAllReferenceObjects Removes all reference objects (if any) from the DirectShapeType.
Public methodRemoveExternallyTaggedGeometry Removes the externally tagged geometry object by its external ID from this DirectShapeType.
Public methodRemoveReferenceObject(ExternalGeometryId) Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType. Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Public methodRemoveReferenceObject(String) Removes any reference objects with the given name from the DirectShapeType. Nothing is done if no reference objects have the given name or if the name is the empty string.
Public methodResetExternallyTaggedGeometry Removes all of the externally tagged geometry in this DirectShapeType.
Public methodSetFamilyName Sets the family name for the DirectShapeType.
Public methodSetOptions Sets the options to use for this DirectShapeType.
Public methodSetShape(IListGeometryObject) Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public methodSetShape(ShapeBuilder) Sets the shape of this object to the one accumulated in the supplied Builder object. If the new shape is identical to the old one, the old shape will be kept.
Public methodSetShape(IListGeometryObject, DirectShapeTargetViewType) Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Public methodUpdateExternallyTaggedGeometry Updates the externally tagged geometry object in the DirectShapeType.
Top
See Also