DirectShapeTypeGetExternallyTaggedGeometry Method |
Gets the externally tagged geometry by its external ID that is stored in this DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ExternallyTaggedGeometryObject GetExternallyTaggedGeometry(
ExternalGeometryId externalId
)
Public Function GetExternallyTaggedGeometry (
externalId As ExternalGeometryId
) As ExternallyTaggedGeometryObject
public:
ExternallyTaggedGeometryObject^ GetExternallyTaggedGeometry(
ExternalGeometryId^ externalId
)
member GetExternallyTaggedGeometry :
externalId : ExternalGeometryId -> ExternallyTaggedGeometryObject
Parameters
- externalId ExternalGeometryId
-
The external ID of the externally tagged geometry that should be obtained.
Return Value
ExternallyTaggedGeometryObject
The externally tagged geometry.
Or
if there is no such externally tagged geometry in the DirectShapeType.
Exceptions
See Also