ElementType Class

Base class for all Types within Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      More

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ElementType : Element

The ElementType type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyCode exampleBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCanBeCopied Determine if this ElementType can create a copy
Public propertyCanBeDeleted Determine if this ElementType can be deleted
Public propertyCanBeRenamed Determine if this ElementType can be renamed
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCode exampleCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyCode exampleDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyCode exampleDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyFamilyName Gets the family name of this element type.
Public propertyCode exampleGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyCode exampleId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyCode exampleLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyNameSet the name for the ElementType.
(Overrides ElementName)
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyCode exampleParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyCode exampleParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyCode exampleUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodDuplicate Duplicates an existing element type and assigns it a new name.
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodCode exampleGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetPreviewImageGet the preview image of an element. This image is similar to what is seen in the Revit UI when selecting the type of an element.
Public methodGetSimilarTypes Obtains a set of types that are similar to this type.
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodCode exampleGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsSimilarType Checks if given type is similar to this type.
Public methodIsValidDefaultFamilyType Identifies if this type is a valid default family type for the given family category id.
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Element types are usually non user visible elements that define instances. For example a wall type is a type that is not visible until an instance of the wall is created.
See Also
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DB.AnalysisConceptualConstructionType
      Autodesk.Revit.DB.ArchitectureContinuousRailType
      Autodesk.Revit.DB.ArchitectureCutMarkType
      Autodesk.Revit.DB.ArchitectureRailingType
      Autodesk.Revit.DB.ArchitectureStairsLandingType
      Autodesk.Revit.DB.ArchitectureStairsPathType
      Autodesk.Revit.DB.ArchitectureStairsRunType
      Autodesk.Revit.DB.ArchitectureStairsType
      Autodesk.Revit.DB.ArchitectureTopographyLinkType
      Autodesk.Revit.DBAssemblyType
      Autodesk.Revit.DBBeamSystemType
      Autodesk.Revit.DBBrowserOrganization
      Autodesk.Revit.DBCADLinkType
      Autodesk.Revit.DBDimensionType
      Autodesk.Revit.DBDirectShapeType
      Autodesk.Revit.DB.ElectricalDistributionSysType
      Autodesk.Revit.DB.ElectricalInsulationType
      Autodesk.Revit.DB.ElectricalTemperatureRatingType
      Autodesk.Revit.DB.ElectricalVoltageType
      Autodesk.Revit.DB.ElectricalWireMaterialType
      Autodesk.Revit.DB.ElectricalWireType
      Autodesk.Revit.DBFabricationPartType
      Autodesk.Revit.DBGroupType
      Autodesk.Revit.DBHostObjAttributes
      Autodesk.Revit.DBImageType
      Autodesk.Revit.DBInsertableObject
      Autodesk.Revit.DBLineAndTextAttrSymbol
      Autodesk.Revit.DB.MechanicalDuctInsulationType
      Autodesk.Revit.DB.MechanicalDuctLiningType
      Autodesk.Revit.DB.MechanicalMechanicalEquipmentSetType
      Autodesk.Revit.DB.MechanicalMEPBuildingConstruction
      Autodesk.Revit.DBMEPAnalyticalConnectionType
      Autodesk.Revit.DBMEPSystemType
      Autodesk.Revit.DBModelTextType
      Autodesk.Revit.DBMultiReferenceAnnotationType
      Autodesk.Revit.DB.PlumbingFluidType
      Autodesk.Revit.DB.PlumbingPipeInsulationType
      Autodesk.Revit.DB.PlumbingPipeScheduleType
      Autodesk.Revit.DBPointCloudType
      Autodesk.Revit.DBRevitLinkType
      Autodesk.Revit.DBSiteLocation
      Autodesk.Revit.DB.StructureAnalyticalLinkType
      Autodesk.Revit.DB.StructureAreaReinforcementType
      Autodesk.Revit.DB.StructureEndTreatmentType
      Autodesk.Revit.DB.StructureFabricAreaType
      Autodesk.Revit.DB.StructureFabricSheetType
      Autodesk.Revit.DB.StructureFabricWireType
      Autodesk.Revit.DB.StructureLoadTypeBase
      Autodesk.Revit.DB.StructurePathReinforcementType
      Autodesk.Revit.DB.StructureRebarBarType
      Autodesk.Revit.DB.StructureRebarBendingDetailType
      Autodesk.Revit.DB.StructureRebarContainerType
      Autodesk.Revit.DB.StructureRebarCoverType
      Autodesk.Revit.DB.StructureRebarHookType
      Autodesk.Revit.DB.StructureRebarShape
      Autodesk.Revit.DB.StructureStructuralConnectionApprovalType
      Autodesk.Revit.DB.StructureStructuralConnectionHandlerType
      Autodesk.Revit.DB.StructureStructuralConnectionType
      Autodesk.Revit.DBTilePattern
      Autodesk.Revit.DBViewFamilyType