DirectShapeTypeAreValidDirectShapeReferenceOptions Method |
Validates that the input DirectShapeReferenceOptions are suitable for creating a direct shape reference object.
If the options specify an ExternalGeometryId, it must not correspond to any existing reference object
belonging to the DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool AreValidDirectShapeReferenceOptions(
DirectShapeReferenceOptions options
)
Public Function AreValidDirectShapeReferenceOptions (
options As DirectShapeReferenceOptions
) As Boolean
public:
bool AreValidDirectShapeReferenceOptions(
DirectShapeReferenceOptions^ options
)
member AreValidDirectShapeReferenceOptions :
options : DirectShapeReferenceOptions -> bool
Parameters
- options DirectShapeReferenceOptions
-
The options to test.
Return Value
Boolean
True if the options can be used to add a reference object to this DirectShapeType.
Exceptions
See Also