DirectShapeTypeHasExternallyTaggedReference Method |
Checks if the externally tagged reference is already present in this DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool HasExternallyTaggedReference(
ExternalGeometryId externalId
)
Public Function HasExternallyTaggedReference (
externalId As ExternalGeometryId
) As Boolean
public:
bool HasExternallyTaggedReference(
ExternalGeometryId^ externalId
)
member HasExternallyTaggedReference :
externalId : ExternalGeometryId -> bool
Parameters
- externalId ExternalGeometryId
-
The external ID of the tagged reference to check for.
Return Value
Boolean
True if the DirectShapeType holds a reference with the specified ExternalGeometryId.
Exceptions
See Also