DirectShapeTypeIsValidUsage Method |
Validates that the ExternallyTaggedGeometryObject's usage is set to an allowed value for a DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidUsage(
ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Function IsValidUsage (
externallyTaggedGeometry As ExternallyTaggedGeometryObject
) As Boolean
public:
bool IsValidUsage(
ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member IsValidUsage :
externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool
Parameters
- externallyTaggedGeometry ExternallyTaggedGeometryObject
-
The geometry to check.
Return Value
Boolean
True if the usage is permitted.
Exceptions
See Also