DirectShapeTypeIsValidShape(IListGeometryObject) Method |
Validates shape to be stored in a DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidShape(
IList<GeometryObject> shape
)
Public Function IsValidShape (
shape As IList(Of GeometryObject)
) As Boolean
public:
bool IsValidShape(
IList<GeometryObject^>^ shape
)
member IsValidShape :
shape : IList<GeometryObject> -> bool
Parameters
- shape IListGeometryObject
-
Shape to be validated represented as a collection of GeometryObjects.
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
Return Value
Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Remarks
This function calls IsValidShape(GeometryObject) to validate each object in the list.
See Also