DirectShapeTypeSetShape(ShapeBuilder) Method |
Sets the shape of this object to the one accumulated in the supplied Builder object.
If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetShape(
ShapeBuilder pBuilder
)
Public Sub SetShape (
pBuilder As ShapeBuilder
)
public:
void SetShape(
ShapeBuilder^ pBuilder
)
member SetShape :
pBuilder : ShapeBuilder -> unit
Parameters
- pBuilder ShapeBuilder
-
A ShapeBuilder object that was used to successfully build geometry to store in this DirectShapeType. The built shape will be
transferred to the DirectShapeType, and the ShapeBuilder object will be reset.
Exceptions
Remarks
This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder.
It is therefore slightly more efficient than the SetShape() routine that accepts GeometryObjects directly as input.
Supplying a ViewShapeBuilder object as argument will cause the view-specific shape of this DirectShapeType to be updated.
Supplying other ShapeBuilder types will update the model shape.
See Also