DirectShapeTypeIsValidShape(IListGeometryObject, DirectShapeTargetViewType) Method |
Validates view-specific shape to be stored in a DirectShapeType. Expects a non-default view type.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidShape(
IList<GeometryObject> shape,
DirectShapeTargetViewType viewType
)
Public Function IsValidShape (
shape As IList(Of GeometryObject),
viewType As DirectShapeTargetViewType
) As Boolean
public:
bool IsValidShape(
IList<GeometryObject^>^ shape,
DirectShapeTargetViewType viewType
)
member IsValidShape :
shape : IList<GeometryObject> *
viewType : DirectShapeTargetViewType -> bool
Parameters
- shape IListGeometryObject
-
Shape of this object expressed as a collection of GeometryObjects.
For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
- viewType DirectShapeTargetViewType
-
The view type this shape is intended for.
Return Value
Boolean
True if the supplied shape passes the validation criteria.
Exceptions
See Also