DirectShapeTypeRemoveReferenceObject(ExternalGeometryId) Method |
Removes any reference object associated with the provided ExternalGeometryId from the DirectShapeType.
Nothing is done if no reference object has the given external ID or if the external ID is an empty string.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void RemoveReferenceObject(
ExternalGeometryId externalId
)
Public Sub RemoveReferenceObject (
externalId As ExternalGeometryId
)
public:
void RemoveReferenceObject(
ExternalGeometryId^ externalId
)
member RemoveReferenceObject :
externalId : ExternalGeometryId -> unit
Parameters
- externalId ExternalGeometryId
-
The ExternalGeometryId of the reference object to be removed.
Exceptions
See Also