DirectShapeTypeHasExternalGeometry Method |
Checks whether the externally tagged geometry is already present in this DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool HasExternalGeometry(
ExternalGeometryId externalId
)
Public Function HasExternalGeometry (
externalId As ExternalGeometryId
) As Boolean
public:
bool HasExternalGeometry(
ExternalGeometryId^ externalId
)
member HasExternalGeometry :
externalId : ExternalGeometryId -> bool
Parameters
- externalId ExternalGeometryId
-
The external ID of the externally tagged geometry to check.
Return Value
Boolean
True if such an externally tagged geometry is already present in this DirectShapeType, false otherwise.
Exceptions
See Also