DirectShapeTypeIsValidShape(ExternallyTaggedGeometryObject) Method |
Validates shape to be stored in a DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsValidShape(
ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Function IsValidShape (
externallyTaggedGeometry As ExternallyTaggedGeometryObject
) As Boolean
public:
bool IsValidShape(
ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member IsValidShape :
externallyTaggedGeometry : ExternallyTaggedGeometryObject -> bool
Parameters
- externallyTaggedGeometry ExternallyTaggedGeometryObject
-
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Return Value
Boolean
True if the supplied shape passes the validation criteria.
Exceptions
Remarks
This function uses the same criteria as IsValidShape(GeometryObject).
See Also