DirectShapeTypeAppendShape(ShapeBuilder) Method |
Append shape built by the supplied ShapeBuilderObject to shape representation stored in this DirectShapeType.
The data stored in the supplied ShapeBuilder object will be cleared.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AppendShape(
ShapeBuilder ShapeBuilder
)
Public Sub AppendShape (
ShapeBuilder As ShapeBuilder
)
public:
void AppendShape(
ShapeBuilder^ ShapeBuilder
)
member AppendShape :
ShapeBuilder : ShapeBuilder -> unit
Parameters
- ShapeBuilder ShapeBuilder
-
The ShapeBuilder object that was used to build the shape to be appended.
Exceptions
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be
joined with the appended geometry. It is up to the caller to ensure that the combination of geometry
will have teh correct appearance in Revit.
This function will bypass extra geometry validation because the built geometry has already been validated by the ShapeBuilder.
It is therefore slightly more efficient than the AppendShape() routine that accepts GeometryObjects directly as input.
See Also