DirectShapeTypeAppendShape(IListGeometryObject) Method |
Appends the collection of GeometryObjects into the model shape representation stored in this DirectShape.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AppendShape(
IList<GeometryObject> pGeomArr
)
Public Sub AppendShape (
pGeomArr As IList(Of GeometryObject)
)
public:
void AppendShape(
IList<GeometryObject^>^ pGeomArr
)
member AppendShape :
pGeomArr : IList<GeometryObject> -> unit
Parameters
- pGeomArr IListGeometryObject
-
Shape expressed as a collection of GeometryObjects.
The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
Exceptions
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be
joined with the appended geometry. It is up to the caller to ensure that the combination of geometry
will have the correct appearance in Revit.
See Also