DirectShapeTypeAppendShape(IListGeometryObject, DirectShapeTargetViewType) Method |
Appends the collection of GeometryObjects into the model or view specific shape representation stored in this DirectShapeType.
Passing DirectShapeTargetViewType.Default as view type will cause the model shape to be updated.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AppendShape(
IList<GeometryObject> pGeomArr,
DirectShapeTargetViewType viewType
)
Public Sub AppendShape (
pGeomArr As IList(Of GeometryObject),
viewType As DirectShapeTargetViewType
)
public:
void AppendShape(
IList<GeometryObject^>^ pGeomArr,
DirectShapeTargetViewType viewType
)
member AppendShape :
pGeomArr : IList<GeometryObject> *
viewType : DirectShapeTargetViewType -> unit
Parameters
- pGeomArr IListGeometryObject
-
Shape expressed as a collection of GeometryObjects.
For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve.
- viewType DirectShapeTargetViewType
-
Passing DirectShapeTargetViewType.Default as view type will cause the default shape to be appended.
Exceptions
Remarks
The existing shape will not be cleared by this function, and intersecting or overlapped geometry will not be
joined with the appended geometry. It is up to the caller to ensure that the combination of geometry
will have the correct appearance in Revit.
See Also