DirectShapeTypeSetShape(IListGeometryObject) Method

Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetShape(
	IList<GeometryObject> pGeomArr
)

Parameters

pGeomArr  IListGeometryObject
Shape of this object expressed as a collection of GeometryObjects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point, Curve and PolyLine.
Exceptions
ExceptionCondition
ArgumentException At least one member of pGeomArr does not satisfy DirectShapeType validation criteria.
ArgumentNullException A non-optional argument was null
See Also