DirectShapeTypeAddReferencePlane(Plane, DirectShapeReferenceOptions) Method |
Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddReferencePlane(
Plane refPlane,
DirectShapeReferenceOptions options
)
Public Sub AddReferencePlane (
refPlane As Plane,
options As DirectShapeReferenceOptions
)
public:
void AddReferencePlane(
Plane^ refPlane,
DirectShapeReferenceOptions^ options
)
member AddReferencePlane :
refPlane : Plane *
options : DirectShapeReferenceOptions -> unit
Parameters
- refPlane Plane
-
The geometry of the new reference plane.
- options DirectShapeReferenceOptions
-
The options that are used to configure the new reference plane.
Exceptions
See Also