DirectShapeTypeGetExternallyTaggedReference Method |
Retrieve a Reference to reference geometry of the DirectShapeType that is associated with a particular ExternalGeometryId.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic Reference GetExternallyTaggedReference(
ExternalGeometryId externalId
)
Public Function GetExternallyTaggedReference (
externalId As ExternalGeometryId
) As Reference
public:
Reference^ GetExternallyTaggedReference(
ExternalGeometryId^ externalId
)
member GetExternallyTaggedReference :
externalId : ExternalGeometryId -> Reference
Parameters
- externalId ExternalGeometryId
-
The ExternalGeometryId of the requested reference object.
Return Value
Reference
A Reference to the externally tagged reference GeometryObject having the provided external ID
or
if there is no reference geometry having the external ID.
Exceptions
See Also