DirectShapeTypeAddReferencePlane(Plane, BoundingBoxUV) Method |
Adds a reference plane to the DirectShapeType. The reference plane can either be bounded or unbounded.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void AddReferencePlane(
Plane refPlane,
BoundingBoxUV boundingBoxUV
)
Public Sub AddReferencePlane (
refPlane As Plane,
boundingBoxUV As BoundingBoxUV
)
public:
void AddReferencePlane(
Plane^ refPlane,
BoundingBoxUV^ boundingBoxUV
)
member AddReferencePlane :
refPlane : Plane *
boundingBoxUV : BoundingBoxUV -> unit
Parameters
- refPlane Plane
-
The geometry of the new reference plane.
- boundingBoxUV BoundingBoxUV
-
If boundingBoxUV is set, the resulting reference plane that is added to the DirectShapeType will be displayed
with those bounds. Note that the specified bounds must not be degenerate.
If boundingBoxUV is not set, reasonable bounds are automatically calculated and applied to the input plane.
The automatic bounds are based on the host direct shape's geometry.
Exceptions
See Also