DirectShapeTypeUpdateExternallyTaggedGeometry Method |
Updates the externally tagged geometry object in the DirectShapeType.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void UpdateExternallyTaggedGeometry(
ExternallyTaggedGeometryObject externallyTaggedGeometry
)
Public Sub UpdateExternallyTaggedGeometry (
externallyTaggedGeometry As ExternallyTaggedGeometryObject
)
public:
void UpdateExternallyTaggedGeometry(
ExternallyTaggedGeometryObject^ externallyTaggedGeometry
)
member UpdateExternallyTaggedGeometry :
externallyTaggedGeometry : ExternallyTaggedGeometryObject -> unit
Parameters
- externallyTaggedGeometry ExternallyTaggedGeometryObject
-
The externally tagged geometry that should be updated in the DirectShapeType.
ExceptionsException | Condition |
---|
ArgumentException |
The input shape does not satisfy DirectShapeType validation criteria.
-or-
A previous version of the externally tagged geometry is not present in this DirectShapeType.
|
ArgumentNullException |
A non-optional argument was null
|
See Also