DirectShapeTypeSetShape(IListGeometryObject, DirectShapeTargetViewType) Method |
Builds the type shape from the supplied collection of GeometryObjects. The objects are copied.
If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void SetShape(
IList<GeometryObject> pGeomArr,
DirectShapeTargetViewType viewType
)
Public Sub SetShape (
pGeomArr As IList(Of GeometryObject),
viewType As DirectShapeTargetViewType
)
public:
void SetShape(
IList<GeometryObject^>^ pGeomArr,
DirectShapeTargetViewType viewType
)
member SetShape :
pGeomArr : IList<GeometryObject> *
viewType : DirectShapeTargetViewType -> unit
Parameters
- pGeomArr IListGeometryObject
-
Shape of this object expressed as a collection of GeometryObjects. These will be copied.
Shape and Category should be consistent: geometry supplied as shape should be valid for the Category
the type object is associated with.
For viewType = DirectShapeTargetViewType::Default, the supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
For viewType = DirectShapeTargetViewType::Plan, the supported types of GeometryObjects are: Point and Curve
- viewType DirectShapeTargetViewType
-
Specifies which target view type to associate the geometry with. The target view type will
decide which views can show this geometry.
Exceptions
See Also