FabricSheet Class

An object that represents an Fabric Sheet Element within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.StructureFabricSheet

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class FabricSheet : Element

The FabricSheet type exposes the following members.

Properties
 NameDescription
Public propertyBendFinalLoopOrientationVector Direction of local Fabric Sheet Y axis in bending polyline LCS.
Public propertyBentFabricBendDirection Specifies which wire direction of the fabric sheet is bent.
Public propertyBentFabricLongitudinalCutLength Specifies the cut length of the fabric sheet perpendicular to the bend edge.
Public propertyBentFabricStraightWiresLocation Specifies the location of straight bars with respect to bent bars in the fabric sheet.
Public propertyCoverOffset The additional cover offset of the Fabric Sheet.
Public propertyCutOverallLength The sheet length after cutting has taken place.
Public propertyCutOverallWidth The sheet length after cutting has taken place.
Public propertyCutSheetMass The sheet mass after cutting has taken place.
Public propertyFabricAreaOwnerId The Fabric Area Id.
Public propertyFabricHostReference Controls if Single Fabric Sheet should be cut by the Host Cover
Public propertyFabricLocation The Fabric Sheet location in the host.
Public propertyFabricNumber Specifies the numerical parameter assigned to the fabric sheet and any sheet of the same type, dimension, material, shape, and partition.
Public propertyHostId The structure element that contains the Fabric Sheet.
Public propertyIsBent The type of fabric sheet. True for bent fabric sheet, false for flat fabric sheet.
Public propertySketchId The id of the Sketch element for this element.
Top
Methods
 NameDescription
Public methodStatic memberCreate(Document, Element, ElementId) Creates a new instance of a single flat Fabric Sheet element within the project.
Public methodStatic memberCode exampleCreate(Document, ElementId, ElementId, CurveLoop) Creates a new instance of a single bent Fabric Sheet element within the project.
Public methodCode exampleGetBendProfile Returns the profile (not including generated fillets) that defines the shape of the Fabric Sheet bending.
Public methodGetBendProfileWithFillets Returns the profile with generated fillets that defines the shape of the Fabric Sheet bending.
Public methodGetReinforcementRoundingManager Returns an object for managing reinforcement rounding override settings.
Public methodCode exampleGetSegmentParameterIdsAndLengths Returns the array of pairs [parameter ID, length] that correspond to segments of a bent fabric sheet (like A, B, C, D etc.).
Public methodGetSheetLocation Gets the position and the orientation of the Fabric Sheet instance.
Public methodGetWireCenterlines Gets a list of curves representing the wires centerlines of the Fabric Sheet in the both distribution directions.
Public methodGetWireCenterlines(WireDistributionDirection) Gets a list of curves representing the wires centerlines of the Fabric Sheet.
Public methodIsCoverOffsetValid Identifies if the specified value is valid for use as a cover offset.
Public methodIsSingleFabricSheetWithinHost Identifies if the specified single Fabric Sheet position is within the host.
Public methodIsUnobscuredInView Checks if this fabric sheet is shown unobscured in a view.
Public methodStatic memberIsValidHost(Element) Checks whether an element is a valid host for fabric sheet.
Public methodStatic memberIsValidHost(Document, ElementId) Checks whether an element is a valid host for fabric sheet.
Public methodPlaceInHost Inserts the single Fabric Sheet instance into the host element.
Public methodCode exampleSetBendProfile Sets new profile that defines the shape of the Fabric Sheet bending.
Public methodSetSegmentLength Sets the value of the bent fabric sheet segment(like A, B, C, D etc.)
Public methodSetUnobscuredInView Sets this fabric sheet to be shown unobscured in a view.
Top
Remarks
Beginning with Revit 2016, fabric sheets can be either flat or bent. Both kinds of fabric sheets are implemented by this FabricSheet class. Fabric sheets are created as either flat or bent. Once created, the kind of a fabric sheet cannot be changed. The Fabric Sheet element is available only in the Autodesk Revit Structure product.
See Also