FabricSheetGetWireCenterlines(WireDistributionDirection) Method

Gets a list of curves representing the wires centerlines of the Fabric Sheet.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public IList<Curve> GetWireCenterlines(
	WireDistributionDirection wireDirection
)

Parameters

wireDirection  WireDistributionDirection
The direction of wire distribution in the Fabric Sheet.

Return Value

IListCurve
The centerline curves.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also