FabricSheetSetSegmentLength Method

Sets the value of the bent fabric sheet segment(like A, B, C, D etc.)

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public void SetSegmentLength(
	ElementId segmentParameterId,
	double value
)

Parameters

segmentParameterId  ElementId
The segment ID of the bent fabric sheet.
value  Double
The length value to set
Exceptions
ExceptionCondition
ArgumentException The given value for value is not a number -or-
ArgumentNullException A non-optional argument was null
ArgumentOutOfRangeException The given value for value must be between 0 and 30000 feet.
See Also