FabricSheetGetBendProfileWithFillets Method |
Returns the profile with generated fillets that defines the shape of the Fabric Sheet bending.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CurveLoop GetBendProfileWithFillets()
Public Function GetBendProfileWithFillets As CurveLoop
public:
CurveLoop^ GetBendProfileWithFillets()
member GetBendProfileWithFillets : unit -> CurveLoop
Return Value
CurveLoop
The bend profile with generated fillets that defines the shape of the fabric sheet bending for bent fabric sheet,
for flat fabric sheet
will be returned.
Remarks
Returned curve loop is created automatically as a result of adding fillets to bend profile.
The returned profile defines the center-curve of a wire.
Note that bent Fabric Sheets can have planar geometry, but flat Fabric Sheets are always planar.
See Also