FabricSheetBentFabricStraightWiresLocation Property |
Specifies the location of straight bars with respect to bent bars in the fabric sheet.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic BentFabricStraightWiresLocation BentFabricStraightWiresLocation { get; set; }
Public Property BentFabricStraightWiresLocation As BentFabricStraightWiresLocation
Get
Set
public:
property BentFabricStraightWiresLocation BentFabricStraightWiresLocation {
BentFabricStraightWiresLocation get ();
void set (BentFabricStraightWiresLocation value);
}
member BentFabricStraightWiresLocation : BentFabricStraightWiresLocation with get, set
Property Value
BentFabricStraightWiresLocation
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: the data-setting method is not applicable to fabric sheets that are flat
|
ArgumentOutOfRangeException |
When setting this property: A value passed for an enumeration argument is not a member of that enumeration
|
InvalidObjectException |
When setting this property: The data-setting method is not applicable to fabric sheets that are flat.
|
Remarks
This parameter applies only to bent fabric sheets.
The side on wich straight wires will be loacted is determined by the start and end point of the first bent profile segment that specifies the direction of the curve loop on plane.
See Also