FabricSheetGetBendProfile Method |
Returns the profile (not including generated fillets) that defines the shape of the Fabric Sheet bending.
Namespace: Autodesk.Revit.DB.StructureAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic CurveLoop GetBendProfile()
Public Function GetBendProfile As CurveLoop
public:
CurveLoop^ GetBendProfile()
member GetBendProfile : unit -> CurveLoop
Return Value
CurveLoop
The profile that defines the shape of the fabric sheet bending for bent fabric sheet, for flat fabric sheet
will be returned.
Remarks
The returned profile defines the center-curve of a wire.
Note that bent Fabric Sheets can have planar geometry, but flat Fabric Sheets are always planar.
Example#region Autodesk.Revit.DB.Structure.FabricSheet.SetBendProfile(Autodesk.Revit.DB.CurveLoop)
private void ModifyBentFabricSheet(Document document, FabricSheet bentFabricSheet)
{
CurveLoop newBendingProfile = CurveLoop.CreateViaOffset(bentFabricSheet.GetBendProfile(), 0.5, new XYZ(0, 0, -1));
bentFabricSheet.SetBendProfile(newBendingProfile);
TaskDialog.Show("Revit", string.Format("Bent Fabric Sheet ID='{0}' modified successfully.", bentFabricSheet.Id.ToString()));
}
#endregion
#Region "Autodesk.Revit.DB.Structure.FabricSheet.SetBendProfile(Autodesk.Revit.DB.CurveLoop)"
Private Sub ModifyBentFabricSheet(document As Document, bentFabricSheet As FabricSheet)
Dim newBendingProfile As CurveLoop = CurveLoop.CreateViaOffset(bentFabricSheet.GetBendProfile(), 0.5, New XYZ(0, 0, -1))
bentFabricSheet.SetBendProfile(newBendingProfile)
TaskDialog.Show("Revit", String.Format(, bentFabricSheet.Id.ToString()))
End Sub
#End Region
No code example is currently available or this language may not be supported.
No code example is currently available or this language may not be supported.
See Also