ElementGetChangeTypeParameter(ElementId) Method

Returns ChangeType associated with a change in a parameter's value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ChangeType GetChangeTypeParameter(
	ElementId parameterId
)

Parameters

parameterId  ElementId
ElementId of parameter for the ChangeType to trigger on.

Return Value

ChangeType
ChangeType that can be used to define a trigger for an Updater, triggering on parameter value change.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
Remarks
remarks: Use this change type to trigger an Updater when the value of an element's parameter changes. Note: This change type will not trigger on newly created or deleted elements or on changes caused by Undo and Redo.
See Also