Dimension Class

An object that represents a dimension within the Revit project.
Inheritance Hierarchy

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Dimension : Element

The Dimension type exposes the following members.

Properties
 NameDescription
Public propertyAboveThe text shown above the segment's value.
Public propertyAreReferencesAvailable Indicates if this dimension's references can be resolved.
Public propertyAreSegmentsEqualIndicates if all segments are forced to be equal.
Public propertyBelowThe text shown below the segment's value.
Public propertyCurve A curve that represents the dimension line.
Public propertyDimensionShapeThe shape of this dimension.
Public propertyDimensionType The dimension style of this dimension.
Public propertyFamilyLabelThe family parameter label of the dimension.
Public propertyHasLeader True if dimension has leader, false otherwise.
Public propertyIsLocked Indicates if this dimension is locked.
Public propertyIsValid Indicates if this dimension is valid.
Public propertyLeaderEndPosition The position of the dimension's leader end point.
Public propertyNameRetrieves or changes the name associated with the Dimension.
Public propertyNumberOfSegmentsThe number of segments for the dimension.
Public propertyOrigin The dimension origin.
Public propertyPrefixThe text shown before the segment's value.
Public propertyReferences Returns an array of geometric references to which the dimension is attached.
Public propertySegmentsThe segments in the dimension.
Public propertySuffixThe text shown after the segment's value.
Public propertyCode exampleTextPosition The position of the dimension text's drag point.
Public propertyValue The value of the dimension.
Public propertyValueOverrideThe text that replaces the segment's value.
Public propertyValueString The dimension value as a user visible string.
Public propertyView Supplies the view that contains the dimension if the dimension is view specific.
Top
Methods
 NameDescription
Public methodHasOneSegment Determines whether a dimension has one segment.
Public methodIsTextPositionAdjustable Indicates if this dimension is supported to set/get TextPosition/LeaderEndPosition.
Public methodResetTextPosition Resets the text position of the dimension to the initial position determined by its type and parameters.
Top
Example
public void GetInfo_Dimension(Dimension dimension)
{
    string message = "Dimension : ";
    // Get Dimension name
    message += "\nDimension name is : " + dimension.Name;

    // Get Dimension Curve
    Autodesk.Revit.DB.Curve curve = dimension.Curve;
    if (curve != null && curve.IsBound)
    {
        // Get curve start point
        message += "\nCurve start point:(" + curve.GetEndPoint(0).X + ", "
             + curve.GetEndPoint(0).Y + ", " + curve.GetEndPoint(0).Z + ")";
        // Get curve end point
        message += "; Curve end point:(" + curve.GetEndPoint(1).X + ", "
             + curve.GetEndPoint(1).Y + ", " + curve.GetEndPoint(1).Z + ")";
    }

    // Get Dimension type name
    message += "\nDimension type name is : " + dimension.DimensionType.Name;

    // Get Dimension view name
    message += "\nDimension view name is : " + dimension.View.Name;

    // Get Dimension reference count
    message += "\nDimension references count is " + dimension.References.Size;

    if (BuiltInCategory.OST_Dimensions == dimension.Category.BuiltInCategory)
    {
        message += "\nDimension is a permanent dimension.";
    }
    else if (BuiltInCategory.OST_Constraints == dimension.Category.BuiltInCategory)
    {
        message += "\nDimension is a constraint element.";
    }


    Autodesk.Revit.UI.TaskDialog.Show("Revit",message);
}
See Also