PathOfTravel Class

An element which holds a graphical representation of the shortest route between two points in the plane of a floor plan view. The shortest route is calculated to go around model geometry visible in the view. Route calculation is affected by properties of the RouteAnalysisSettings element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.AnalysisPathOfTravel

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class PathOfTravel : Element

The PathOfTravel type exposes the following members.

Properties
 NameDescription
Public propertyLineStyle The line style of the path.
Public propertyPathEnd The end point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.
Public propertyPathMidpoint The midpoint of the path. The Z coordinate will equal the view's level elevation.
Public propertyPathStart The start point of the path. The Z coordinate will equal the view's level elevation. To update path calculations, call update.
Top
Methods
 NameDescription
Public methodStatic memberCreate(View, XYZ, XYZ) Creates a new path of travel between two points.
Public methodStatic memberCreate(View, XYZ, XYZ, PathOfTravelCalculationStatus) Creates a new path of travel between two points and provides creation result status.
Public methodStatic memberCreateMapped(View, IListXYZ, IListXYZ) Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points.
Public methodStatic memberCreateMapped(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) Creates multiple new paths of travel by mapping each of a set of start points to each of a set of end points and provides creation result statuses.
Public methodStatic memberCreateMultiple(View, IListXYZ, IListXYZ) Creates multiple new paths of travel between same size sets of start and end points.
Public methodStatic memberCreateMultiple(View, IListXYZ, IListXYZ, IListPathOfTravelCalculationStatus) Creates multiple new paths of travel between same size sets of start and end points and provides creation result statuses.
Public methodStatic memberFindEndsOfShortestPaths For a floor plan view, calculates the paths from each start point to its closest destination and return the path end points.
Public methodStatic memberFindShortestPaths For a floor plan view, calculates paths from each start point to its closest destinations. Returns the path, represented by an array of XYZ points.
Public methodStatic memberFindStartsOfLongestPathsFromRooms For a floor plan view, calculates paths from points inside rooms to the closests of the destinations. Returns the start points of the longest path(s). If multiple paths have the same longest length, returns multiple start points.
Public methodGetCurves Gets the array of curves representing the path of travel.
Public methodGetWaypoints return the waypoints set for the Path of Travel
Public methodInsertWaypoint Insert a waypoint at the specified index
Public methodStatic memberIsInRevealObstaclesMode Returns current state of Reveal Obstacles mode for the given view.
Public methodRemoveWaypoint Remove a waypoint.
Public methodStatic memberSetRevealObstaclesMode Sets Reveal Obstacles mode for the given view.
Public methodSetWaypoint Updates the specified waypoint.
Public methodUpdate Updates the path of travel by recalculating the path between the original start and end points.
Public methodStatic memberUpdateMultiple(Document, IListElementId) Updates the specified paths of travel by recalculating each path using their original start and end points.
Public methodStatic memberUpdateMultiple(Document, IListElementId, IListPathOfTravelCalculationStatus) Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.
Top
See Also