ElementGetChangeTypeGeometry Method |
Returns ChangeType associated with a change in the geometry of an element
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static ChangeType GetChangeTypeGeometry()
Public Shared Function GetChangeTypeGeometry As ChangeType
public:
static ChangeType^ GetChangeTypeGeometry()
static member GetChangeTypeGeometry : unit -> ChangeType
Return Value
ChangeType
ChangeType that can be used to define a trigger for an Updater,
triggering on a geometry change in an element
Remarks
Use this change type to trigger an Updater when the geometry of an element
changes. For example, changes like cutting a hole in a wall or
adjusting its height are considered to be geometric changes.
Note: This change type will not trigger on newly created or deleted elements
or on changes caused by Undo and Redo.
See Also