Family Class

An element that represents a custom family (not a system family) in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBFamily

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Family : Element

The Family type exposes the following members.

Properties
 NameDescription
Public propertyCurtainPanelHorizontalSpacing For Curtain Panel families, the horizontal spacing of the driving mesh.
Public propertyCurtainPanelTilePattern For Curtain Panel families, the choice of tile pattern.
Public propertyCurtainPanelVerticalSpacing For Curtain Panel families, the vertical spacing of the driving mesh.
Public propertyCode exampleFamilyCategoryRetrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public propertyFamilyCategoryId The id of the category or sub category in which the elements that this family could generate reside.
Public propertyFamilyPlacementType Identifies the type of placement required by a given family.
Public propertyIsConceptualMassFamily Whether the Family is a Conceptual Mass family.
Public propertyIsCurtainPanelFamily Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public propertyIsEditable True if the family supports editing, false otherwise.
Public propertyIsInPlace True if the family is an in-place family, false if the family is a loadable family.
Public propertyIsOwnerFamily True if the family is the owner family for its own editable document, false otherwise.
Public propertyIsParametric Identifies whether the family contains parametric relations between some of its elements.
Public propertyIsUserCreated Determine whether the family has been defined by the user.
Public propertyShowSpatialElementCalculationPoint For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public propertyStructuralCodeName The family's structural code name.
Public propertyStructuralFamilyNameKey The family's structural section shape name key.
Public propertyStructuralMaterialType The family's structural material type.
Public propertyStructuralSectionShape The family's structural section shape.
Top
Methods
 NameDescription
Public methodCanHaveStructuralSection Identifies if this Family can have a structural section.
Public methodStatic memberCanLoadFamilies Checks whether the document is in a state that allows the loading of families.
Public methodExtractPartAtom Writes a PartAtom XML from the contents of a family object.
Public methodGetFamilySymbolIds Gets the ids of the FamilySymbols owned by this Family.
Public methodCode exampleGetFamilyTypeParameterValues Returns all applicable values for a FamilyType parameter of this family.
Public methodHasLargeSketches Checks whether the family contains sketches with a large number of elements.
Public methodIsAppropriateCategoryId Identifies if the input category id can be assigned as the new category for this family.
Top
Remarks
Custom families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of families. The Family element represents the entire family that consists of a collection of types, such as an 'I Beam'. You can think of that object as representing the entire family file. The Family object contains a number of FamilySymbol elements. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that type placed the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project.
Example
public void GetInfoForSymbols(Family family)
{
    StringBuilder message = new StringBuilder("Selected element's family name is : " + family.Name);
    ISet<ElementId> familySymbolIds = family.GetFamilySymbolIds();

    if (familySymbolIds.Count == 0)
    {
        message.AppendLine("Contains no family symbols.");
    }
    else
    {
        message.AppendLine("The family symbols contained in this family are : ");

        // Get family symbols which is contained in this family
        foreach (ElementId id in familySymbolIds)
        {
            FamilySymbol familySymbol = family.Document.GetElement(id) as FamilySymbol;
            // Get family symbol name
            message.AppendLine("\nName: " + familySymbol.Name);
            foreach (ElementId materialId in familySymbol.GetMaterialIds(false))
            {
                Material material = familySymbol.Document.GetElement(materialId) as Material;
                message.AppendLine("\nMaterial : " + material.Name);
            }
        }
    }

    TaskDialog.Show("Revit",message.ToString());
}
See Also