Family Class

An element that represents a custom family (not a system family) in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBFamily

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Family : Element

The Family type exposes the following members.

Properties
 NameDescription
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyCode exampleBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCode exampleCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyCurtainPanelHorizontalSpacing For Curtain Panel families, the horizontal spacing of the driving mesh.
Public propertyCurtainPanelTilePattern For Curtain Panel families, the choice of tile pattern.
Public propertyCurtainPanelVerticalSpacing For Curtain Panel families, the vertical spacing of the driving mesh.
Public propertyCode exampleDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyCode exampleDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyCode exampleFamilyCategoryRetrieves or sets a Category object that represents the category or sub category in which the elements ( this family could generate ) reside.
Public propertyFamilyCategoryId The id of the category or sub category in which the elements that this family could generate reside.
Public propertyFamilyPlacementType Identifies the type of placement required by a given family.
Public propertyCode exampleGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyCode exampleId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIsConceptualMassFamily Whether the Family is a Conceptual Mass family.
Public propertyIsCurtainPanelFamily Whether the Family is a Curtain Panel family. Curtain Panel family symbols are used as the ObjectTypes of DividedSurface elements.
Public propertyIsEditable True if the family supports editing, false otherwise.
Public propertyIsInPlace True if the family is an in-place family, false if the family is a loadable family.
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsOwnerFamily True if the family is the owner family for its own editable document, false otherwise.
Public propertyIsParametric Identifies whether the family contains parametric relations between some of its elements.
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsUserCreated Determine whether the family has been defined by the user.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyCode exampleLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyCode exampleParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyCode exampleParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyShowSpatialElementCalculationPoint For families that can have a calculation point for spatial elements, hide or show the calculation point. SpatialElementCalculationPoint elements.
Public propertyStructuralCodeName The family's structural code name.
Public propertyStructuralFamilyNameKey The family's structural section shape name key.
Public propertyStructuralMaterialType The family's structural material type.
Public propertyStructuralSectionShape The family's structural section shape.
Public propertyCode exampleUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveStructuralSection Identifies if this Family can have a structural section.
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodStatic memberCanLoadFamilies Checks whether the document is in a state that allows the loading of families.
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public methodExtractPartAtom Writes a PartAtom XML from the contents of a family object.
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetFamilySymbolIds Gets the ids of the FamilySymbols owned by this Family.
Public methodCode exampleGetFamilyTypeParameterValues Returns all applicable values for a FamilyType parameter of this family.
Public methodCode exampleGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodCode exampleGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodHasLargeSketches Checks whether the family contains sketches with a large number of elements.
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodIsAppropriateCategoryId Identifies if the input category id can be assigned as the new category for this family.
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Custom families within the Revit API represented by three objects - Family, FamilySymbol and FamilyInstance. Each object plays a significant part in the structure of families. The Family element represents the entire family that consists of a collection of types, such as an 'I Beam'. You can think of that object as representing the entire family file. The Family object contains a number of FamilySymbol elements. The FamilySymbol object represents a specific set of family settings within that Family and represents what is known in the Revit user interface as a Type, such as 'W14x32'. The FamilyInstance object represents an actual instance of that type placed the Autodesk Revit project. For example the FamilyInstance would be a single instance of a W14x32 column within the project.
Example
public void GetInfoForSymbols(Family family)
{
    StringBuilder message = new StringBuilder("Selected element's family name is : " + family.Name);
    ISet<ElementId> familySymbolIds = family.GetFamilySymbolIds();

    if (familySymbolIds.Count == 0)
    {
        message.AppendLine("Contains no family symbols.");
    }
    else
    {
        message.AppendLine("The family symbols contained in this family are : ");

        // Get family symbols which is contained in this family
        foreach (ElementId id in familySymbolIds)
        {
            FamilySymbol familySymbol = family.Document.GetElement(id) as FamilySymbol;
            // Get family symbol name
            message.AppendLine("\nName: " + familySymbol.Name);
            foreach (ElementId materialId in familySymbol.GetMaterialIds(false))
            {
                Material material = familySymbol.Document.GetElement(materialId) as Material;
                message.AppendLine("\nMaterial : " + material.Name);
            }
        }
    }

    TaskDialog.Show("Revit",message.ToString());
}
See Also