ColorFillScheme Class

Represents a color scheme could be used to colorfy elements in floor plan views and section views.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBColorFillScheme

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class ColorFillScheme : Element

The ColorFillScheme type exposes the following members.

Properties
 NameDescription
Public propertyAreaSchemeId Represents the id of AreaScheme of area plan views that this scheme could be applied to.
Public propertyCategoryId Represents the element category that can be colored by this scheme.
Public propertyIsByRange Represents if the parameter values in entries are treated as value range or not.
Public propertyIsLinkedFilesIncluded Represent if the scheme includes entries whose parameter values are based on elements from linked files.
Public propertyParameterDefinition Represents the parameter of the elements that this scheme could be used to color.
Public propertyStorageType Represents the type of parameter values stored in entries.
Public propertyTitle Represents the title displayed in ColorFillLegend.
Top
Methods
 NameDescription
Public methodAddEntry Adds new entry to the scheme.
Public methodAreEntriesConsistentWithScheme Checks whether the entries can be set to the scheme or not.
Public methodCanDefineByRange Checks whether the scheme entries can be explained by range.
Public methodCanRemoveEntry Checks whether entry can be removed from the scheme.
Public methodCanUpdateEntry Checks whether entry exists in the scheme and not the same as input one.
Public methodDuplicate Generates a copy of current scheme.
Public methodGetEntries Retrieves copies of all entries.
Public methodGetFormatOptions Returns the FormatOptions of the scheme.
Public methodGetSupportedParameterIds Retrieves collection of all parameters supported by the scheme.
Public methodIsEntryConsistentWithScheme Checks whether an entry can be added to the scheme or not.
Public methodIsValidParameterDefinitionId Checks whether the input parameter id can be applied to the scheme.
Public methodIsValidSchemeName Checks whether the name is valid for new generated scheme.
Public methodRemoveEntry Removes an entry whose parameter value is the same as the input from the scheme
Public methodSetEntries Update scheme entries in batch mode.
Public methodSetFormatOptions Sets the FormatOptions of the scheme.
Public methodSortEntries Sorts the scheme entries ascending.
Public methodUpdateEntry Updates the scheme entry with the same parameter value as the input entry.
Top
Remarks

A color scheme is based on element category and one of the category parameter, it contains a set of ColorFillSchemeEntry which stores parameter value, color, fill pattern and other entry data. The entry paramater values may be a range or a single value, based on the IsByRange property. Then elements with the specified category could be colored with the color and fill pattern of matching entry whose parameter value or value range matches the element parameter value.

You can retrieve the entries with GetEntries, or modify entries with AddEntry(ColorFillSchemeEntry), RemoveEntry(ColorFillSchemeEntry), UpdateEntry(ColorFillSchemeEntry) and [M:Autodesk.Revit.DB.ColorFillScheme.SetEntries(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})].

Unlike most of the other elements, the color scheme works in an "asynchronous" way in UI:

  1. If document elements change, the color scheme will not be updated immediately.
  2. If color schemes changes, the document elements will not be updated immediately too.

API works slightly different with UI:

  1. GetEntries will return the entries corresponding to the latest document elements status immediately.
  2. The entries modification operation will retrieve the latest entries with GetEntries at first, and then modify those entries by request, but document elements will still not be updated immediately.
  3. To modify multiple entries, it's better to use [M:Autodesk.Revit.DB.ColorFillScheme.SetEntries(System.Collections.Generic.IList`1{Autodesk.Revit.DB.ColorFillSchemeEntry})] but not modify them one by one with other methods for better performance.

Notes:

  • To apply a color scheme whose CategoryId property is OST_Areas to an area plan view, the AreaSchemeId property must be the same as the view if it is not used as a template.
  • To generate a new color scheme, you have to use Duplicate(String) method to duplicate form an existing one.
  • There should not exist two entries values that are the same in a color scheme. if the StorageType property is Double, then the value accuracy should be based on FormatOptions property.
See Also