AreaReinforcement Class

An object that represents an Area Reinforcement within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.StructureAreaReinforcement

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AreaReinforcement : Element

The AreaReinforcement type exposes the following members.

Properties
 NameDescription
Public propertyAdditionalBottomCoverOffset Additional offset from the bottom or interior cover reference.
Public propertyAdditionalTopCoverOffset Additional offset from the top or exterior cover reference.
Public propertyAreaReinforcementType Retrieves the type of the Area Reinforcement.
Public propertyAssemblyInstanceId The id of the assembly instance to which the element belongs.
(Inherited from Element)
Public propertyCode exampleBoundingBoxRetrieves a box that circumscribes all geometry of the element.
(Inherited from Element)
Public propertyCategoryRetrieves a Category object that represents the category or sub category in which the element resides.
(Inherited from Element)
Public propertyCode exampleCreatedPhaseId Id of a Phase at which the Element was created.
(Inherited from Element)
Public propertyCode exampleDemolishedPhaseId Id of a Phase at which the Element was demolished.
(Inherited from Element)
Public propertyCode exampleDesignOptionReturns the design option to which the element belongs.
(Inherited from Element)
Public propertyDirection Retrieve the Major Direction of the Area Reinforcement.
Public propertyDocumentReturns the Document in which the Element resides.
(Inherited from Element)
Public propertyCode exampleGeometryRetrieves the geometric representation of the element.
(Inherited from Element)
Public propertyGroupId The id of the group to which an element belongs.
(Inherited from Element)
Public propertyCode exampleId A unique identifier for an Element in an Autodesk Revit project.
(Inherited from Element)
Public propertyIsModifiable Identifies if the element is modifiable.
(Inherited from Element)
Public propertyIsTransient Indicates whether an element is transient or permanent.
(Inherited from Element)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from Element)
Public propertyLevelId The id of the level associated with the element.
(Inherited from Element)
Public propertyCode exampleLocationThis property is used to find the physical location of an element within a project.
(Inherited from Element)
Public propertyNameA human readable name for the Element.
(Inherited from Element)
Public propertyOwnerViewId The id of the view that owns the element.
(Inherited from Element)
Public propertyCode exampleParameterBuiltInParameterRetrieves a parameter from the element given a parameter id.
(Inherited from Element)
Public propertyParameterDefinitionRetrieves a parameter from the element based on its definition.
(Inherited from Element)
Public propertyParameterGuidRetrieves a parameter from the element given a GUID for a shared parameter.
(Inherited from Element)
Public propertyCode exampleParametersRetrieves a set containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyParametersMapRetrieves a map containing all of the parameters that are contained within the element.
(Inherited from Element)
Public propertyPinned Identifies if the element has been pinned to prevent changes.
(Inherited from Element)
Public propertyCode exampleUniqueId A stable unique identifier for an element within the document.
(Inherited from Element)
Public propertyVersionGuid Get the element version Guid.
(Inherited from Element)
Public propertyViewSpecific Identifies if the element is owned by a view.
(Inherited from Element)
Public propertyWorksetId Get Id of the Workset which owns the element.
(Inherited from Element)
Top
Methods
 NameDescription
Public methodArePhasesModifiable Returns true if the properties CreatedPhaseId and DemolishedPhaseId can be modified for this Element.
(Inherited from Element)
Public methodCanBeHiddenIndicates if the element can be hidden in the view.
(Inherited from Element)
Public methodCanBeLocked Identifies if the element can be locked.
(Inherited from Element)
Public methodCanDeleteSubelement Checks if given subelement can be removed from the element.
(Inherited from Element)
Public methodCanHaveTypeAssigned Identifies if the element can have a type assigned.
(Inherited from Element)
Public methodChangeTypeId(ElementId) Changes the type of the element.
(Inherited from Element)
Public methodStatic memberConvertRebarInSystemToRebars Converts all RebarInSystem elements owned by the input AreaReinforcement to equivalent Rebar elements.
Public methodStatic memberCreate(Document, Element, XYZ, ElementId, ElementId, ElementId) Creates a new AreaReinforcement object based on a host boundary.
Public methodStatic memberCode exampleCreate(Document, Element, IListCurve, XYZ, ElementId, ElementId, ElementId) Creates a new AreaReinforcement object from an array of curves. This method replaces the NewAreaReinforcement method, which has been deprecated.
Public methodDeleteEntity Deletes the existing entity created by %schema% in the element
(Inherited from Element)
Public methodDeleteSubelement Removes a subelement from the element.
(Inherited from Element)
Public methodDeleteSubelements Removes the subelements from the element.
(Inherited from Element)
Public methodDispose
(Inherited from Element)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluateAllParameterValues Evaluates all the parameters' values of the element.
(Inherited from Element)
Public methodEvaluateParameterValues Evaluate the parameters' values of the element on the given parameter ID set.
(Inherited from Element)
Public methodGetBoundaryCurveIds Retrieves the set of curves forming the boundary of the Area Reinforcement.
Public methodGetDependentElements Get all elements that, from a logical point of view, are the children of this Element.
(Inherited from Element)
Public methodGetEntity Returns the existing entity corresponding to the Schema if it has been saved in the Element, or an invalid entity otherwise.
(Inherited from Element)
Public methodGetEntitySchemaGuids Returns the Schema guids of any Entities stored in this element.
(Inherited from Element)
Public methodGetExternalFileReference Gets information pertaining to the external file referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReference Gets the ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferenceExpanded Gets the collection of ExternalResourceReference associated with a specified external resource type.
(Inherited from Element)
Public methodGetExternalResourceReferences Gets the map of the external resource references referenced by the element.
(Inherited from Element)
Public methodGetExternalResourceReferencesExpanded Gets the expanded map of the external resource references referenced by the element.
(Inherited from Element)
Public methodCode exampleGetGeneratingElementIds Returns the ids of the element(s) that generated the input geometry object.
(Inherited from Element)
Public methodGetGeometryObjectFromReference Retrieve one geometric primitive contained in the element given a reference.
(Inherited from Element)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetHostId The element that contains the Area Reinforcement.
Public methodGetLayerDirection Gets the direction of the layer. The lines are distributed along this direction.
Public methodGetLineFromLayerAtIndex Gets the line from the desired layer at the specified index.
Public methodGetMaterialArea Gets the area of the material with the given id.
(Inherited from Element)
Public methodGetMaterialIds Gets the element ids of all materials present in the element.
(Inherited from Element)
Public methodGetMaterialVolume Gets the volume of the material with the given id.
(Inherited from Element)
Public methodGetMonitoredLinkElementIds Provides the link instance IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMonitoredLocalElementIds Provides the local element IDs when the element is monitoring.
(Inherited from Element)
Public methodGetMovedLineTransform Returns a transform representing the movement of the line relative to its default position along the direction of the desired layer.
Public methodGetNumberOfLines Gets the number of lines on the specified layer. It also counts the excluded ones.
Public methodGetOrderedParameters Gets the parameters associated to the element in order.
(Inherited from Element)
Public methodGetParameterRetrieves a parameter from the element given identifier.
(Inherited from Element)
Public methodGetParameterFormatOptions Returns a FormatOptions override for the element Parameter, or a default FormatOptions if no override exists.
(Inherited from Element)
Public methodGetParametersRetrieves the parameters from the element via the given name.
(Inherited from Element)
Public methodGetPhaseStatus Gets the status of a given element in the input phase
(Inherited from Element)
Public methodGetRebarInSystemIds Returns the ids of the RebarInSystem elements owned by the AreaReinforcement element.
Public methodGetSubelements Returns the collection of element subelements.
(Inherited from Element)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodCode exampleGetTypeId Returns the identifier of this element's type.
(Inherited from Element)
Public methodGetValidTypes Obtains a set of types that are valid for this element.
(Inherited from Element)
Public methodHasPhases Returns true if this Element has the properties CreatedPhaseId and DemolishedPhaseId.
(Inherited from Element)
Public methodIsCreatedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsDemolishedPhaseOrderValid Returns true if createdPhaseId and demolishedPhaseId are in order.
(Inherited from Element)
Public methodIsExternalFileReference Determines whether this Element represents an external file.
(Inherited from Element)
Public methodIsHiddenIdentifies if the element has been permanently hidden in the view.
(Inherited from Element)
Public methodIsLayerActive Identifies if the layer is active or not.
Public methodIsLineIncluded Checks whether the line from the desired layer at the specified position is included or not.
Public methodIsMonitoringLinkElement Indicate whether an element is monitoring any elements in any linked models.
(Inherited from Element)
Public methodIsMonitoringLocalElement Indicate whether an element is monitoring other local elements.
(Inherited from Element)
Public methodIsPhaseCreatedValid Returns true if createdPhaseId is an allowed value for the property CreatedPhaseId in this Element.
(Inherited from Element)
Public methodIsPhaseDemolishedValid Returns true if demolishedPhaseId is an allowed value for the property DemolishedPhaseId in this Element.
(Inherited from Element)
Public methodIsUnobscuredInView Checks if Area Reinforcement is shown unobscured in a view.
Public methodIsValidType(ElementId) Checks if given type is valid for this element.
(Inherited from Element)
Public methodLookupParameterAttempts to find a parameter on the element which has the given name.
(Inherited from Element)
Public methodMoveLine This method applies the translation to the line from the desired layer, at the specified position. If the line was already moved, the method will concatenate the translation with the existing movement. The line will be translated only along the direction of the specified layer.
Public methodRefersToExternalResourceReference Determines whether this Element uses external resources associated with a specified external resource type.
(Inherited from Element)
Public methodRefersToExternalResourceReferences Determines whether this Element uses external resources.
(Inherited from Element)
Public methodStatic memberRemoveAreaReinforcementSystem Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Public methodResetMovedLineTransform Reset the transformation representing the movement of the line relative to its default position along the direction of the specified layer. The moved line transform will be set to Identity.
Public methodSetEntity Stores the entity in the element. If an Entity described by the same Schema already exists, it is overwritten.
(Inherited from Element)
Public methodSetLayerActive Sets if the desired layer is active or not.
Public methodSetLineIncluded Sets if the line from desired layer at the specified position is included or not.
Public methodSetUnobscuredInView Sets Area Reinforcement to be shown unobscured in a view.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.
Example
public void GetInfo_AreaReinforcement(AreaReinforcement areaReinforcement)
{
    string message = "AreaReinforcement : ";

    // Show the AreaReinforcement Type information
    //message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    // Show the AreaReinforcement bar information
    IList<ElementId> rebarInSystemIds = areaReinforcement.GetRebarInSystemIds();
    message += "\nNumber of distinct bar shapes : " + rebarInSystemIds.Count;

    for (int i = 0; i < rebarInSystemIds.Count; i++)
    {
        RebarInSystem ris = doc.GetElement(rebarInSystemIds[0]) as RebarInSystem;
        message += "\nBar count : " + ris.Quantity;
        message += "\nBar type name : " + ris.Name;
        message += "\nBar length : " + ris.LookupParameter("Bar Length").AsDouble();
    }

    // Show the AreaReinforcement Curves information
    IList<ElementId> curveIds = areaReinforcement.GetBoundaryCurveIds();
    message += "\nArea Reinforcement has " + curveIds.Count + " boundary curves.";
    foreach (Autodesk.Revit.DB.ElementId ii in curveIds)
    {
        AreaReinforcementCurve reinCurve = doc.GetElement(ii) as AreaReinforcementCurve;
        if (null == reinCurve)
        {
            continue;
        }
        Curve curve = reinCurve.Curve; // get the location curve
        XYZ start = curve.GetEndPoint(0);  // get the start point of the curve
        XYZ end = curve.GetEndPoint(1);    // get the end point of the curve
        message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
        message += "\n       End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    TaskDialog.Show("Revit", message);
}
See Also