AreaReinforcement Class

An object that represents an Area Reinforcement within the Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.StructureAreaReinforcement

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class AreaReinforcement : Element

The AreaReinforcement type exposes the following members.

Properties
 NameDescription
Public propertyAdditionalBottomCoverOffset Additional offset from the bottom or interior cover reference.
Public propertyAdditionalTopCoverOffset Additional offset from the top or exterior cover reference.
Public propertyAreaReinforcementType Retrieves the type of the Area Reinforcement.
Public propertyDirection Retrieve the Major Direction of the Area Reinforcement.
Top
Methods
 NameDescription
Public methodStatic memberConvertRebarInSystemToRebars Converts all RebarInSystem elements owned by the input AreaReinforcement to equivalent Rebar elements.
Public methodStatic memberCreate(Document, Element, XYZ, ElementId, ElementId, ElementId) Creates a new AreaReinforcement object based on a host boundary.
Public methodStatic memberCode exampleCreate(Document, Element, IListCurve, XYZ, ElementId, ElementId, ElementId) Creates a new AreaReinforcement object from an array of curves. This method replaces the NewAreaReinforcement method, which has been deprecated.
Public methodGetBoundaryCurveIds Retrieves the set of curves forming the boundary of the Area Reinforcement.
Public methodGetHostId The element that contains the Area Reinforcement.
Public methodGetLayerDirection Gets the direction of the layer. The lines are distributed along this direction.
Public methodGetLineFromLayerAtIndex Gets the line from the desired layer at the specified index.
Public methodGetMovedLineTransform Returns a transform representing the movement of the line relative to its default position along the direction of the desired layer.
Public methodGetNumberOfLines Gets the number of lines on the specified layer. It also counts the excluded ones.
Public methodGetRebarInSystemIds Returns the ids of the RebarInSystem elements owned by the AreaReinforcement element.
Public methodIsLayerActive Identifies if the layer is active or not.
Public methodIsLineIncluded Checks whether the line from the desired layer at the specified position is included or not.
Public methodIsUnobscuredInView Checks if Area Reinforcement is shown unobscured in a view.
Public methodMoveLine This method applies the translation to the line from the desired layer, at the specified position. If the line was already moved, the method will concatenate the translation with the existing movement. The line will be translated only along the direction of the specified layer.
Public methodStatic memberRemoveAreaReinforcementSystem Deletes the specified AreaReinforcement, and converts its RebarInSystem elements to equivalent Rebar elements.
Public methodResetMovedLineTransform Reset the transformation representing the movement of the line relative to its default position along the direction of the specified layer. The moved line transform will be set to Identity.
Public methodSetLayerActive Sets if the desired layer is active or not.
Public methodSetLineIncluded Sets if the line from desired layer at the specified position is included or not.
Public methodSetUnobscuredInView Sets Area Reinforcement to be shown unobscured in a view.
Top
Remarks
This object derived from the Element base object and such supports all the methods of that object such as the ability to retrieve the parameters of that object. The Area Reinforcement element is available only in the Autodesk Revit Structure product.
Example
public void GetInfo_AreaReinforcement(AreaReinforcement areaReinforcement)
{
    string message = "AreaReinforcement : ";

    // Show the AreaReinforcement Type information
    //message += "\nType : " + areaReinforcement.AreaReinforcementType.Name;

    // Show the AreaReinforcement bar information
    IList<ElementId> rebarInSystemIds = areaReinforcement.GetRebarInSystemIds();
    message += "\nNumber of distinct bar shapes : " + rebarInSystemIds.Count;

    for (int i = 0; i < rebarInSystemIds.Count; i++)
    {
        RebarInSystem ris = doc.GetElement(rebarInSystemIds[0]) as RebarInSystem;
        message += "\nBar count : " + ris.Quantity;
        message += "\nBar type name : " + ris.Name;
        message += "\nBar length : " + ris.LookupParameter("Bar Length").AsDouble();
    }

    // Show the AreaReinforcement Curves information
    IList<ElementId> curveIds = areaReinforcement.GetBoundaryCurveIds();
    message += "\nArea Reinforcement has " + curveIds.Count + " boundary curves.";
    foreach (Autodesk.Revit.DB.ElementId ii in curveIds)
    {
        AreaReinforcementCurve reinCurve = doc.GetElement(ii) as AreaReinforcementCurve;
        if (null == reinCurve)
        {
            continue;
        }
        Curve curve = reinCurve.Curve; // get the location curve
        XYZ start = curve.GetEndPoint(0);  // get the start point of the curve
        XYZ end = curve.GetEndPoint(1);    // get the end point of the curve
        message += "\nCurve: Start point (" + start.X + ", " + start.Y + ", " + start.Z + ")";
        message += "\n       End point (" + end.X + ", " + end.Y + ", " + end.Z + ")";
    }

    TaskDialog.Show("Revit", message);
}
See Also