DatumPlane Class

A base class representing a datum surface (level, grid or reference plane) in Autodesk Revit.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBDatumPlane
      Autodesk.Revit.DBGrid
      Autodesk.Revit.DBLevel
      Autodesk.Revit.DBReferencePlane

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class DatumPlane : Element

The DatumPlane type exposes the following members.

Properties
 NameDescription
Top
Methods
 NameDescription
Public methodAddLeader Adds a default Leader for the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public methodCanBeVisibleInView Checks if the datum plane can be visible in the view.
Public methodGetCurvesInView Gets a collection of curves representing the DatumPlane element in the given view.
Public methodGetDatumExtentTypeInView Identifies whether the curve representing the datum plane is displayed according to its actual 3d extents, or else according to a view specific setting.
Public methodGetLeader Gets a copy of the leader applied to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public methodGetPropagationViews Gets a list of candidate views which are parallel to the current view and to which the extents of the datum may be propagated.
Public methodHasBubbleInView Identifies if the DatumPlane has bubble or not.
Public methodHideBubbleInView Hides the bubble in a view. This method does not apply to Reference planes.
Public methodIsBubbleVisibleInView Identifies if the bubble is visible or not in a view.
Public methodIsCurveValidInView Checks if the curve is valid to be as the extents for the datum plane in a view. The curve must be bound and coincident with the original one of the datum plane.
Public methodIsLeaderValid Identifies if the leader valid or not for this DatumPlane. This method does not apply to Reference planes (which do not support leaders).
Public methodMaximize3DExtents Computes the 3d extents of all model geometry and levels, and extends the 3d extents of this datum surface to include the model extents.
Public methodPropagateToViews Propagates the extents applied to this datum in the view to the specified parallel views.
Public methodSetCurveInView Sets the extents to match the curve.
Public methodSetDatumExtentType Sets whether the curve representing the datum plane is displayed according to its 3d extents, or else according to a view specific setting.
Public methodSetLeader Sets the leader to the indicated end of the datum plane. This method does not apply to Reference planes (which do not support leaders).
Public methodShowBubbleInView Shows the bubble in a view. This method does not apply to Reference planes.
Top
Remarks
A DatumPlane represents a 3d surface with finite extents. It can be either a rectangle with arbitrary orientation, or a cylinder whose axis is parallel to the project z-axis. If a datum is visible in a plan or section view, it will be displayed as one or more curves. These curves are determined by the intersection of the datum surface with the cut plane of the view. By default, the extents of these curves reflect the 3d extents of the datum surface. If the surface is a plane, then the extents represent the projection of the surface onto the cut plane. This matters, for example, when viewing a datum plane, really a 3d rectangle, along one of its diagonals. The extents of the curve do not vary with the location of the view, because we use the projection of the rectangle and not the actual intersection. If the surface is a cylinder, then the extents reflect the actual intersection of the surface with the cut plane. In addition, the curves that represent a DatumPlane can be modified on a view specific basis. In this case, the ends of the curve no longer reflect the 3d extents of the datum.
See Also