ElementGetValidTypes(Document, ICollectionElementId) Method

Obtains a set of types that are valid for all given elements.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public static ICollection<ElementId> GetValidTypes(
	Document document,
	ICollection<ElementId> elementIds
)

Parameters

document  Document
The document.
elementIds  ICollectionElementId
A collection of element IDs.

Return Value

ICollectionElementId
A set of element IDs of types that are valid for these elements or an empty set if any element cannot have a type assigned.
Exceptions
ExceptionCondition
ArgumentException Thrown when at least one of the elements does not exist in the document.
ArgumentNullException A non-optional argument was null
See Also