ElementIsValidType(Document, ICollectionElementId, ElementId) Method |
Checks if given type is valid for the set of elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static bool IsValidType(
Document document,
ICollection<ElementId> elementIds,
ElementId typeId
)
Public Shared Function IsValidType (
document As Document,
elementIds As ICollection(Of ElementId),
typeId As ElementId
) As Boolean
public:
static bool IsValidType(
Document^ document,
ICollection<ElementId^>^ elementIds,
ElementId^ typeId
)
static member IsValidType :
document : Document *
elementIds : ICollection<ElementId> *
typeId : ElementId -> bool
Parameters
- document Document
-
The document.
- elementIds ICollectionElementId
-
A collection of element IDs.
- typeId ElementId
-
ElementId of the type to check.
Return Value
Boolean
True if all elements can have a type assigned and this type is valid for all elements, false otherwise.
Exceptions
Remarks
A type is valid for the set of elements if it is valid for each and every element in the set.
See Also