Material Class

Represents a material element within an Autodesk Revit project.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBMaterial

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class Material : Element

The Material type exposes the following members.

Properties
 NameDescription
Public propertyCode exampleAppearanceAssetId The ElementId of the AppearanceAssetElement.
Public propertyColor The color of the material.
Public propertyCutBackgroundPatternColor The color of the material cut background pattern.
Public propertyCutBackgroundPatternId The id of the FillPatternElement used as the background pattern of faces with this material in cut views.
Public propertyCutForegroundPatternColor The color of the material cut foreground pattern.
Public propertyCutForegroundPatternId The id of the FillPatternElement used as the foreground pattern of faces with this material in cut views.
Public propertyMaterialCategory The name of the material category, e.g. 'Wood'
Public propertyMaterialClass The name of the general material type, e.g. 'Wood.'
Public propertyShininess The shininess of the material.
Public propertySmoothness The smoothness of the material.
Public propertyStructuralAssetId The ElementId of the structural PropertySetElement.
Public propertySurfaceBackgroundPatternColor The color of the material surface background pattern.
Public propertySurfaceBackgroundPatternId The id of the FillPatternElement used as the background pattern of faces with this material in normal views.
Public propertySurfaceForegroundPatternColor The color of the material surface foreground pattern.
Public propertySurfaceForegroundPatternId The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.
Public propertyThermalAssetId The ElementId of the thermal PropertySetElement.
Public propertyTransparency The transparency of the material.
Public propertyUseRenderAppearanceForShading True to use the render appearance settings for shaded view appearance; false to use the material's color and transparency value for shaded view appearance.
Top
Methods
 NameDescription
Public methodClearMaterialAspect Removes an aspect from the material.
Public methodStatic memberCode exampleCreate Creates a new material.
Public methodCode exampleDuplicate Duplicates the material
Public methodStatic memberIsMaterialOrValidDefault Validates whether the specified element id is a material element.
Public methodStatic memberIsNameUnique Validates whether the material name is unique in document.
Public methodSetMaterialAspectByPropertySet Sets an aspect of the material to a shared property set.
Top
Example
private void GetMaterialInformation(Material material)
{
   StringBuilder message = new StringBuilder("Material : " + material.Name);
   //color of the material
   message.Append(string.Format("\nColor: Red[{0}]; Green[{1}]; Blue[{2}]",
                   material.Color.Red, material.Color.Green, material.Color.Blue));

   //foreground cut pattern and pattern color of the material
   FillPatternElement cutForegroundPattern = material.Document.GetElement(material.CutForegroundPatternId) as FillPatternElement;
   if (null != cutForegroundPattern)
   {
      message.Append("\nCut Foreground Pattern: " + cutForegroundPattern.Name);
      message.Append(string.Format("\nCut Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.CutForegroundPatternColor.Red, material.CutForegroundPatternColor.Green, material.CutForegroundPatternColor.Blue));
   }

   //foreground surface pattern and pattern color of the material
   FillPatternElement surfaceForegroundPattern = material.Document.GetElement(material.SurfaceForegroundPatternId) as FillPatternElement;
   if (null != surfaceForegroundPattern)
   {
      message.Append("\nSurface Foreground Pattern: " + surfaceForegroundPattern.Name);
      message.Append(string.Format("\nSurface Foreground Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.SurfaceForegroundPatternColor.Red, material.SurfaceForegroundPatternColor.Green, material.SurfaceForegroundPatternColor.Blue));
   }

   //background cut pattern and pattern color of the material
   FillPatternElement cutBackgroundPattern = material.Document.GetElement(material.CutBackgroundPatternId) as FillPatternElement;
   if (null != cutBackgroundPattern)
   {
      message.Append("\nCut Background Pattern: " + cutBackgroundPattern.Name);
      message.Append(string.Format("\nCut Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.CutBackgroundPatternColor.Red, material.CutBackgroundPatternColor.Green, material.CutBackgroundPatternColor.Blue));
   }

   //background surface pattern and pattern color of the material
   FillPatternElement surfaceBackgroundPattern = material.Document.GetElement(material.SurfaceBackgroundPatternId) as FillPatternElement;
   if (null != surfaceBackgroundPattern)
   {
      message.Append("\nSurface Background Pattern: " + surfaceBackgroundPattern.Name);
      message.Append(string.Format("\nSurface Background Pattern Color: Red[{0}]; Green[{1}]; Blue[{2}]",
                      material.SurfaceBackgroundPatternColor.Red, material.SurfaceBackgroundPatternColor.Green, material.SurfaceBackgroundPatternColor.Blue));
   }

   //some shading property of the material
   int shininess = material.Shininess;
   message.Append("\nShininess: " + shininess);
   int smoothness = material.Smoothness;
   message.Append("\nSmoothness: " + smoothness);
   int transparency = material.Transparency;
   message.Append("\nTransparency: " + transparency);

   TaskDialog.Show("Revit", message.ToString());
}
See Also