RebarBendingDetailType Class

Type for rebar bending detail elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DB.StructureRebarBendingDetailType

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntax
public class RebarBendingDetailType : ElementType

The RebarBendingDetailType type exposes the following members.

Properties
 NameDescription
Public propertyAngularDimensionsDisplayOption Identifies the angular dimensions display options.
Public propertyAngularDimensionsEnabled Identifies if any angular dimensions will be shown or not.
Public propertyAngularDimensionsForHooksEnabled Identifies if the angular dimensions which has a reference set on a hook will be shown or not.
Public propertyAngularDimensionsMeasurementOptions Identifies the measurement option for angular dimensions.
Public propertyAngularDimensionsOffset Identifies the offset of the angular dimensions.
Public propertyAngularDimensionTextPosition Identifies the text position with respect to dimension line.
Public propertyAngularDimensionTypeId Identifies the Id of the angular dimension type which is used to show dimensions.
Public propertyBendDiameterDimensionsEnabled Identifies if any radial or diameter dimensions will be shown or not.
Public propertyBendDiameterDimensionsForHooksEnabled Identifies if radial or diameter dimensions will be shown for hook fillets. This property has a meaning only if BendDiameterDimensionsEnabled is set to true.
Public propertyBendDiameterDimensionsForSegmentsEnabled Identifies if radial or diameter dimensions will be shown for the bends between segments. Radial or diameter dimesions for arc segments will be shown by default. This property has a menaning only if BendDiameterDimensionsEnabled is set to true.
Public propertyBendDiameterDimensionType Identifies what type of bend diameter dimensions will be shown (radial or diameter).
Public propertyDetailLevel Identifies the level of detail in which the Bending Detail will be represented.
Public propertyDiameterDimensionTypeId Identifies the Id of the diameter dimension type which is used to show dimensions.
Public propertyDisplayMode The display mode for the bending detail.
Public propertyMultipleValuesIndicatorOption Identifies the option of how multiple values will be represented.
Public propertyOrthogonalAndOverallDimesionsEnabled Identifies if orthogonal and overall dimensions are displayed.
Public propertyRadialDimensionTypeId Identifies the Id of the radial dimension type which is used to show dimensions.
Public propertyRepresentaionOf3DShapes Identifies how the Bending Detail will represent the 3D shapes.
Public propertySchematicHeight Determine the height of the box where the schematic Bending Detail will be represented.
Public propertySchematicWidth Determine the width of the box where the schematic Bending Detail will be represented.
Public propertySegmentLengthDimensionsEnabled Identifies if any segment length dimensions will be shown or not.
Public propertySegmentLengthDimensionsForHooksEnabled Identifies if segment length dimensions for hooks will be shown or not. If this property is true, the SegmentLengthDimensionsEnabled should also be true to see segment length dimensions for hooks.
Public propertySegmentLengthDimensionsOffset Identifies the offset of the segment length dimensions.
Public propertySegmentLengthDimensionTextPosition Identifies the text position with respect to dimension line.
Public propertySegmentLengthDimensionTypeId Identifies the Id of the linear dimension type which is used to show segments length.
Public propertySegmentLengthsDisplayOption Identifies if the segment lengths are represented using dimensions or just as text.
Public propertySegmentLengthsForArcsDisplayOption Identifies if the arc segment lengths are represented using dimensions or just as text. Only RebarShapes whose definition is RebarShapeDefinitionByArc are considered that have arc segments.
Public propertySegmentsRepresentation Identifies how the bending detail will represent the segments of the bar.
Public propertyTagTypeId Identifies the Id of the tag type which is used in the Bending Detail representation.
Top
Methods
 NameDescription
Public methodStatic memberCreateObsolete.
Creates a new RebarBendingDetailType object.
Public methodStatic memberCreateRealistic Creates a new RebarBendingDetailType object for full representations.
Public methodStatic memberCreateSchematic Creates a new RebarBendingDetailType object for schematic representations.
Top
See Also