FamilyExtractPartAtom Method |
Writes a PartAtom XML from the contents of a family object.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic void ExtractPartAtom(
string xmlFilePath
)
Public Sub ExtractPartAtom (
xmlFilePath As String
)
public:
void ExtractPartAtom(
String^ xmlFilePath
)
member ExtractPartAtom :
xmlFilePath : string -> unit
Parameters
- xmlFilePath String
- The xml file to be saved.
Exceptions
Remarks
This method is designed for a family loaded into a document in session. So it will skip the type catalog file.
To extract the PartAtom XML from a family file on disk, use Application.ExtractPartAtomFromFamilyFile()
See Also