FamilyIsParametric Property |
Identifies whether the family contains parametric relations
between some of its elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool IsParametric { get; }
Public ReadOnly Property IsParametric As Boolean
Get
public:
property bool IsParametric {
bool get ();
}
member IsParametric : bool with get
Property Value
Boolean
RemarksA family is parametric if it contains parameter-driven relations between
its elements, such as labeled dimensions or locked tangential joins.
Parametric families containing large sketches may cause performance
problems. Caution is therefore advised before adding any constraints to
a yet non-parametric family that already contains large sketches.
See [!:DoesContainLargeSketches()].
See Also