FamilyFamilyCategoryId Property |
The id of the category or sub category in which the elements that this family could generate reside.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic ElementId FamilyCategoryId { get; set; }
Public Property FamilyCategoryId As ElementId
Get
Set
public:
property ElementId^ FamilyCategoryId {
ElementId^ get ();
void set (ElementId^ value);
}
member FamilyCategoryId : ElementId with get, set
Property Value
ElementId
ExceptionsException | Condition |
---|
ArgumentException |
When setting this property: The input category id cannot be assigned as the new category for this family.
|
ArgumentNullException |
When setting this property: A non-optional argument was null
|
InvalidOperationException |
When setting this property: The family is not an owner family for its own editable document.
|
See Also