FamilyHasLargeSketches Method |
Checks whether the family contains sketches with a large number of elements.
Namespace: Autodesk.Revit.DBAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic bool HasLargeSketches()
Public Function HasLargeSketches As Boolean
public:
bool HasLargeSketches()
member HasLargeSketches : unit -> bool
Return Value
Boolean
Remarks
Families containing large sketches (typically with 300+ elements) may cause
performance problems in parametric families (see
IsParametric).
Thus, before adding any constraints to a family (which will make the family
parametric,) this method can be queried and the decision about whether the
family should indeed be turned parametric may be deferred to the end-user.
See Also