PathOfTravelUpdateMultiple(Document, IListElementId) Method |
Updates the specified paths of travel by recalculating each path using their original start and end points.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static int UpdateMultiple(
Document adoc,
IList<ElementId> elementsToUpdate
)
Public Shared Function UpdateMultiple (
adoc As Document,
elementsToUpdate As IList(Of ElementId)
) As Integer
public:
static int UpdateMultiple(
Document^ adoc,
IList<ElementId^>^ elementsToUpdate
)
static member UpdateMultiple :
adoc : Document *
elementsToUpdate : IList<ElementId> -> int
Parameters
- adoc Document
-
Document of elements to be updated.
- elementsToUpdate IListElementId
-
The list of ElementIdof the paths to update.
Return Value
Int32
number of successfully updated elements
Exceptions
Remarks
For unsuccessfully updated elements, Revit will post warnings.
See Also