PathOfTravelUpdateMultiple(Document, IListElementId, IListPathOfTravelCalculationStatus) Method |
Updates the specified paths of travel by recalculating each path using their original start and end points and provides creation result statuses.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static int UpdateMultiple(
Document adoc,
IList<ElementId> elementsToUpdate,
out IList<PathOfTravelCalculationStatus> resultStatus
)
Public Shared Function UpdateMultiple (
adoc As Document,
elementsToUpdate As IList(Of ElementId),
<OutAttribute> ByRef resultStatus As IList(Of PathOfTravelCalculationStatus)
) As Integer
public:
static int UpdateMultiple(
Document^ adoc,
IList<ElementId^>^ elementsToUpdate,
[OutAttribute] IList<PathOfTravelCalculationStatus>^% resultStatus
)
static member UpdateMultiple :
adoc : Document *
elementsToUpdate : IList<ElementId> *
resultStatus : IList<PathOfTravelCalculationStatus> byref -> int
Parameters
- adoc Document
-
Document of elements to be updated.
- elementsToUpdate IListElementId
-
The list of ElementIdof the paths to update.
- resultStatus IListPathOfTravelCalculationStatus
-
Result statuses of each path of travel creation.
The order of statuses corresponds to the order of elements in the array passed to the function.
Return Value
Int32
number of successfully updated elements
Exceptions
Remarks
For unsuccessfully updated elements, Revit will post warnings.
See Also