PathOfTravelFindStartsOfLongestPathsFromRooms Method |
For a floor plan view, calculates paths from points inside rooms to the closests of the destinations.
Returns the start points of the longest path(s). If multiple paths have the same longest length, returns multiple start points.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<XYZ> FindStartsOfLongestPathsFromRooms(
View DBView,
IList<XYZ> destinationPoints
)
Public Shared Function FindStartsOfLongestPathsFromRooms (
DBView As View,
destinationPoints As IList(Of XYZ)
) As IList(Of XYZ)
public:
static IList<XYZ^>^ FindStartsOfLongestPathsFromRooms(
View^ DBView,
IList<XYZ^>^ destinationPoints
)
static member FindStartsOfLongestPathsFromRooms :
DBView : View *
destinationPoints : IList<XYZ> -> IList<XYZ>
Parameters
- DBView View
-
The floor plan view to use when computing the points.
- destinationPoints IListXYZ
-
Destination points. The input Z coordinates are ignored and set to the view's level elevation.
Return Value
IListXYZ
Start points of the paths with longest lengths.
The array is empty if there are no valid paths from any points in rooms to any of the destination points.
Exceptions
Remarks
The entire plan is divided in small tiles, and the distance to the closest destination point
is calculated for each tile center point. Only tile center points that are located in rooms in the view are taken into account.
See Also