PathOfTravelFindEndsOfShortestPaths Method |
For a floor plan view, calculates the paths from each start point to its closest destination and return the path end points.
Namespace: Autodesk.Revit.DB.AnalysisAssembly: RevitAPI (in RevitAPI.dll) Version: 25.0.0.0 (25.0.0.0)
Syntaxpublic static IList<XYZ> FindEndsOfShortestPaths(
View DBView,
IList<XYZ> destinationPoints,
IList<XYZ> startPoints
)
Public Shared Function FindEndsOfShortestPaths (
DBView As View,
destinationPoints As IList(Of XYZ),
startPoints As IList(Of XYZ)
) As IList(Of XYZ)
public:
static IList<XYZ^>^ FindEndsOfShortestPaths(
View^ DBView,
IList<XYZ^>^ destinationPoints,
IList<XYZ^>^ startPoints
)
static member FindEndsOfShortestPaths :
DBView : View *
destinationPoints : IList<XYZ> *
startPoints : IList<XYZ> -> IList<XYZ>
Parameters
- DBView View
-
The floor plan view to use when computing the points.
- destinationPoints IListXYZ
-
Destination points. The input Z coordinates are ignored and set to the view's level elevation.
- startPoints IListXYZ
-
Start points for which shortest path end points are calculated.
Return Value
IListXYZ
End points of paths calculated from each start point to its corresponding closest destination.
If a path cannot be calculated the corresponsing end point is set to the corresponding start point.
Exceptions
Remarks
The calculation is done in a floor plan with one or more destinationPoints and one or more startPoints.
The shortest path is calculated from each start point to its corresponding closest destination.
See Also